RMS Home | Guide Writing | Test Server | New Servers | Latest Reviews

Author Topic: Running as admin with UAC disabled...  (Read 2209 times)

0 Members and 1 Guest are viewing this topic.

Offline iro_ori

Running as admin with UAC disabled...
« on: Feb 11, 2015, 02:29 pm »
I'm having an issue on my laptop where I can't change the resolution of my game. I change it, but it stays the same. But, when I run as admin, it changes and also my settings change. It's weird. It's like it loads 2 different settings for when I run as admin and when I don't. Different settings = different hotkey saves, grf's, res, etc.

And I have UAC disabled.

Anyone know how to fix this?

Advertisement

Offline Triper

Re: Running as admin with UAC disabled...
« Reply #1 on: Feb 11, 2015, 04:04 pm »
What you probably have is that without administrator permission, windows doesn't let the game make changes related to its files.

Offline Rider

Re: Running as admin with UAC disabled...
« Reply #2 on: Feb 11, 2015, 06:41 pm »
Maybe you are running the game from a protected drive?

Usually it is best to avoid running the game as Admin but sadly it's the only easy solution because it is difficult to identify and fix the exact cause of the problem in most cases. You could try trouble shooting by changing compatibility mode, installing it in a different drive, add exception to the firewall & anti-virus, making sure you have all the required drives and softwares installed and if nothing helps you could add the game to the DEP.

Offline Tokeiburu

Re: Running as admin with UAC disabled...
« Reply #3 on: Feb 12, 2015, 01:13 am »
Is your game installed outside of a system directory? You should be running it in a folder like C:\Games\RO, not in C:\Program Files\...

These folders require admin privileges, otherwise the game resets to default settings.

Offline iro_ori

Re: Running as admin with UAC disabled...
« Reply #4 on: Feb 12, 2015, 02:00 am »
Is your game installed outside of a system directory? You should be running it in a folder like C:\Games\RO, not in C:\Program Files\...

These folders require admin privileges, otherwise the game resets to default settings.

it was in downloads

i moved it to your suggestion but still same thing. i guess ill try reinstalling there.

Offline lokiro

Re: Running as admin with UAC disabled...
« Reply #5 on: Apr 02, 2015, 08:49 am »
Hello, this is a very popular issue.
Here's one way to solve it.