RMS Home | Guide Writing | Test Server | New Servers | Latest Reviews

Author Topic: RagRay Patch. i need them!  (Read 6796 times)

0 Members and 1 Guest are viewing this topic.

Offline Madara

RagRay Patch. i need them!
« on: Feb 10, 2012, 05:25 am »
what should i do i cant retrieve ragray patch!! can i do it manually??

Advertisement

Offline Madara

Re: RagRay Patch. i need them!
« Reply #1 on: Feb 10, 2012, 06:19 am »
oh nevermind prob solved.but how do i chnge the view?its so damn close

Offline Triper

Re: RagRay Patch. i need them!
« Reply #2 on: Feb 10, 2012, 12:00 pm »
Ragray is dead since november. Use rsu patchers to do the patch now if you don't know that[yes, I know that you've that part solved but advice is always nice to prevent future problems].

To change the view you need to diff the exe and select a different view from the original.

Offline Myteriouss

Re: RagRay Patch. i need them!
« Reply #3 on: Feb 10, 2012, 01:56 pm »
I recommend Miruku. http://miruku.rathena.org/

Quote
Miruku is a full replacement for the RagRay project. It is a simple installer aimed to provide users with a one click experience to install kRO Ragnarok & kRO Renewal.

Offline yC

Re: RagRay Patch. i need them!
« Reply #4 on: Feb 10, 2012, 06:52 pm »
I thought you are looking for an answer like "You use the mouse scroll to change the view distance in-game".  Otherwise on the technical side, what Tripper say but if you are using some server provided client you might have to stick to it.

Offline Madara

Re: RagRay Patch. i need them!
« Reply #5 on: Feb 10, 2012, 11:38 pm »
Ragray is dead since november. Use rsu patchers to do the patch now if you don't know that[yes, I know that you've that part solved but advice is always nice to prevent future problems].

To change the view you need to diff the exe and select a different view from the original.

 /omg i didn't know i can use rsu to patch ragray.thanks yC!
 /hmm which exe because there are many exes in ragray folder..i use my own server btw..

Offline Triper

Re: RagRay Patch. i need them!
« Reply #6 on: Feb 11, 2012, 07:37 am »
Ragray was just a tool to patch kro client easier without many work and to evade the annoying "Can't patch" and "??????" errors.
Rsu is the actualized version of it since, +/- at near November, Gravity changed the way how people connect to the game and Ragray wasn't enough to patch the new files.

To use Rsu you should use both 2 exe - rsu-kro-renewal-lite.exe and rsu-kro-rag-lite.exe or something near that[one at a time ofc].

Offline Madara

Re: RagRay Patch. i need them!
« Reply #7 on: Feb 11, 2012, 09:32 am »
thanks for your info it helped me alot. and which exe should i diff to modify the zooming range.any idea?

Offline Triper

Re: RagRay Patch. i need them!
« Reply #8 on: Feb 11, 2012, 11:04 am »
http://rathena.org/wiki/Diff
http://rathena.org/wiki/Hexing#Creating_custom_RagRE_client_using_a_DIFF_patcher
and http://rathena.org/board/topic/53420-shins-diff-patcher/

Read the third first but all the theory is on the first and second links[that's more of a nerdy thing so you can sorta skip it if you're not on that and just use the tools to do that for you like a boss].

Basically you just need to get the prog on the last link, the plugin somewhere on the same first post on that page[the weesomething plugin thing] and see where is the option to diff the exe you get from http://subversion.assembla.com/svn/weetools/clients/

You should have a default zoom, a bit bigger zoom[2x more or something], a 8x more zoom and a free zoom if it's like the last time I used something like that option. I prefer the 8x more or the 2x zoom but that's a preferential thing.

Do not forget that you will have many options too choose to add to your exe when diffing but many of them can give you errors when being mixed soon or later so keeping it to the simple/essential as possible is sometimes the best.

Offline Buckyx

Re: RagRay Patch. i need them!
« Reply #9 on: Feb 26, 2012, 04:09 am »
solved my problem.. ... ... not enough words
« Last Edit: Feb 26, 2012, 04:15 am by Buckyx »

Offline avatarofwill

Re: RagRay Patch. i need them!
« Reply #10 on: May 23, 2012, 11:47 am »
erm..need help.. i used ragray before and i downloaded rsu-kro-rag-lite and rsu-kro-renewal-lite to try and update my ragray files..but always fail to get patch_allow.txt..can anyone help me please?

Offline Triper

Re: RagRay Patch. i need them!
« Reply #11 on: May 23, 2012, 02:35 pm »
Did you missed some old patch? If you missed some old patchs then the rsu patcher won't be able to get them since kro patchers don't support them anymore. You will have to re-download the client and then do the last patchs with rsu patchers.

Offline avatarofwill

Re: RagRay Patch. i need them!
« Reply #12 on: May 23, 2012, 02:37 pm »
yeap..like a year ago..haha..so i guess no other way then..thanx