RMS Home | Guide Writing | Test Server | New Servers | Latest Reviews

Author Topic: AI.lua error  (Read 42642 times)

0 Members and 1 Guest are viewing this topic.

Offline joannahas

AI.lua error
« on: Oct 24, 2008, 11:15 am »
Hi..i'm having this "AI.lua error" window popping out when i use 'summon homunculus'. Help, please? =\
Everytime i log into that character, it pops out and i can't return to my character

Advertisement

Offline Pandora

Re: AI.lua error
« Reply #1 on: Oct 24, 2008, 01:55 pm »
Update your sakray to make sure you have the AI folder in your RO folder.
heRO is a great friendly, sociable yet WoE active, unique and fun server of 5/5/3 rates with a great community, give it a try!



Click here to find out more about heRO!

Offline Guest

Re: AI.lua error
« Reply #2 on: Oct 24, 2008, 02:49 pm »
if you can, show us a screen shot of your AI folder =3

Offline joannahas

Re: AI.lua error
« Reply #3 on: Oct 24, 2008, 09:59 pm »
Hmm, i don't think i have sakray in my FeelRo folder =O




This is what happened when i tried to log into my character



And here's my AI folder

Offline Guest

Re: AI.lua error
« Reply #4 on: Oct 24, 2008, 10:13 pm »
x3 i believe (not 100% sure this is what causes the problem) that your issue is that the mir AI stuff, is suppose to go into a folder called "USER_AI", but from the looks of things, you seem to have deleted the original AI stuff, and just replaced it with the mirAI

in which case, you need to find an original copy of the AI and put that into your current AI folder, then throw your mirAI stuff into a folder titled USER_AI, which is also in the current AI folder


lol if im wrong someone tell me k? x3
« Last Edit: Oct 24, 2008, 10:19 pm by JJJ »

Offline joannahas

Re: AI.lua error
« Reply #5 on: Oct 24, 2008, 11:31 pm »
Where can i find the original AI folder? =X

Offline Guest

Re: AI.lua error
« Reply #6 on: Oct 24, 2008, 11:59 pm »
^^ here ya go

File Front

Offline joannahas

Re: AI.lua error
« Reply #7 on: Oct 25, 2008, 02:38 am »
Thanks! :D
So i just replace it into my user_ai folder?
Hmm, that ai error window thingy still pops out..

Offline Guest

Re: AI.lua error
« Reply #8 on: Oct 25, 2008, 03:18 am »
put the mir AI files (the ones you orginially had in your AI folder) into a folder called USER_AI
then put the files you just got, into the AI folder

Offline Pow

Re: AI.lua error
« Reply #9 on: Oct 25, 2008, 03:38 am »
Update your sakray to make sure you have the AI folder in your RO folder.

This doesn't always work, if people download the latest Sakray, the AI folder isn't packed in with it - and updating it yields nothing.

Gravity really needs to fix their mistakes quicker xP

-Pow
Divided we stand, together we fall.
There isn't any god that can save us all
So don't pray on your knees, just beg on your hands
There is no belief in this promised land

Offline joannahas

Re: AI.lua error
« Reply #10 on: Oct 25, 2008, 03:50 am »
Thank you soo much! :D
It's working now :D

Offline Guest

Re: AI.lua error
« Reply #11 on: Oct 25, 2008, 03:58 am »
lol imo, it doesn't help that the mirAI doesn't really come with instructions that say "leave your old AI files intact, then make a new folder called USER_AI and put the mirAI in there" (or does it? i dunno i forget already XD)

Offline Brian

Re: AI.lua error
« Reply #12 on: Oct 25, 2008, 08:03 am »
reinstall your ro folder
currently playing at raijero

Offline cheesestix

Re: AI.lua error
« Reply #13 on: Oct 29, 2008, 03:46 am »
Every RO installation is supposed to have an AI folder with an USER_AI folder inside of it. Both folders should have their own AI.lua, which is what controls the homunculus. The AI folder is for the default controls, and the USER_AI is for a custom file. You can switch between the two different AI using /hoai in-game.

Also, if your server has mercenaries, you should have AI_M.lua in both folders as well. I've found that AI_M.lua doesn't come with sakray updates for the most part. You can probably find one on the iRO website though.
Don't worry, be happy =(