rsu patchers

Started by zantanzuken, Oct 28, 2011, 07:57 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


seems to be a common problem... i downloaded the segmented files for ragnarok... unpacked it correctly... ran the patcher...

and now its getting stuck on '2011-09-28data_j.gpf'
Edit: and '2011-08-30data_j.gpf' on rsu renewal.

it will download up to (what i'm assuming is bytes) 24,300,000 bytes, then stop suddenly before the last 3000, it will then stop, reset itself, try to redownload the whole thing again... hiccup in the same location, then skip the file and all files after it, stating its done.

assuming this isnt normal? can attach a picture if you want.


How many times you tried?  Sometimes it happens. 

Make sure you have write permission to the RO folder.  Make sure you have enough space in your hard drive for the download.

Try to patch the other way around (renewal first if you patched kro first previously)?  Not sure if this will help.


over and over.... and over....

Edit: ran in compatability for windows xp sp3, and windows 98... nothing. ran in read only mode, nothing. downloaded the patcher from every download mirror... nothing. made sure that all the other files and folders in the ragnarok directory were un-read only, they were. searched forum for similar problems and the fixes to them, nothing worked. have even gone as far as to try and download the real kRO patcher, but couldnt get to the right page on the website >.>
Edit to my edit: 414 gigs free out of 465.. nope thats not it either.

i've been trying every day, at diffrent times of the day, on both patchers, and they both get stuck at 70 and 30% (respectively)

if i could download those files seperately from the patcher there would be no problem right?

also... seperate from that... i can get the game to run but all of my text is fuzzy... unreadable. assuming thats a problem with the patcher, which is why i stated it first.



still having issues... dont know what to do.

solved my text problem, so i suppose i'll just play and hope for no errors while waiting for a new patcher that will mabye work for me?  :'(


Okay, try the latest rsu patchers download from here and report back if it works.

I see there's a new one just released today.


I'm currently having the exact same problems, even with the new patcher. the patcher fails at 2011-09-28data_j.gpf and 2011-08-30data_j.gpf
zantanzuken, did you find a solution yet?


I was able to pass 2011-09-28data_j.gpf and made it until 2011-09-28data_j3.gpf on my ragray client. But I had to go sleep and it was just a test with another server's lite files on it. So, I didn't bother to complete it. But I will though when I use a fresh copy of my ragray or kRO-RMS.

I just downloaded the RMS' kRO 072711 and rsu-kro-rag-lite was able to patch process complete with 2011-11-something.

I just started rsu-kro-renewal-lite and I will wait for it to complete.

What does the RSU patcher use as a save point? Because for my Thor Patcher, it creates "dejavu.dat" and if I delete it, it resets to the first patch on my FTP.
[color=limegreen]DejavuRO's[/color] [color=red]Grand Opening: [color=blue]12/16/11[/color][/color]

[color=maroon]Guild Package[/color]

[email protected]


If you can't get "pass" a dated patch and you sure all your files are the latest, there is no alternative except to try again until it "passes" the point.  It is not uncommon for the original kRO patchers to stuck like that.  We are just spoiled by the great performance of the rsu patchers.

Fallenone, I ask that question too regarding the "save point".  the patch something .inf seems to get modified every time I patch but I can't see the content ever change.  Maybe the "save point" references are now something within the grf? or in some files in the data etc files?


Hi i just downloaded a while ago the 12parts kRO 07-27-2011 in RMS downloads and when i extract all of it and patched it with RSU it failed around something like 2011-04-20 and I tried several time and still not workin. Then i tried Ragnarok Replay and still failed to connect to the server. What should i do to finish the patch till the last maintenance(kRO today's maintenance)? Thx for those who will advise me xD


Digz123, I can't see why a kRO 07-27-2011 client would try to patch from 2011-04-20.  It does not need to.  Something must be wrong.


Digz, you probably have the old RSU patchers. Get the latest one dated 11-02-11.
[color=limegreen]DejavuRO's[/color] [color=red]Grand Opening: [color=blue]12/16/11[/color][/color]

[color=maroon]Guild Package[/color]

[email protected]


still having issues with it, but so far have only crashed twice while moving between areas on my server.


From what I remember of last time I had to re install, the most resent RMS files work wonders, but if they are older then that you run into a road block. I remember reading over on eAthena that kRO shut down one of its old patch servers and that was causing the problem.

Make sure you're using the right patchers, you only really need to patch kRO and renewal.