kRO Related

Started by Aurora™, Oct 02, 2011, 09:27 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Well, here's the deal. At this rate, I'm unable to participate in the staff I am a part of due to the issues I am having.

I'm slightly frustrated, as I've never had to deal with a technical issues that I couldn't fix,so bare with me.

Originally, I was using Ragray (as that's what I always use,and have had no issues before this), but installing that (even with other servers) gives me a Failed to Receive Patch Update, no matter how many times I reinstalled. So, I proceeded to manually install kRO and kRO-RE. Each time I've reinstalled, tampered with the files, ran everything as an administrator, switched folders countless times, but nothing has changed the errors I receive when trying to patch.

First, I received: ?????? ??? ??????

Then: ??????? ??? ?? ????

I'm honestly at a loss, but am told no one else is having issues with kRO.

Anyone know what to do here? Does it pertain to using Windows 7? I honestly searched Google and here, and found nothing (or at least no fix that would help).


Did you try to Right Click -> Properties -> Compatibility -> Run this program in compatibility mode -> WinXP SP 1/2/3?

Or check your firewall and add an exception? Check your anti-virus' firewall too, if it have one, and add an exception.

If none of these things solves it. I don't know what else. For me anyway. D:


I had a similar situation.  The last time I updated my files was before the start of this summer.  When I came back just recently, I re-ran RagRay, but when I tried to level at Scarabs on a certain server, I got Gravity errors out the wazoo.  When I reran RagRay, I kept getting messages about my client being fully updated, which made me go wtf...

So I went to redownload kRO from RagRay...except their site was gone, it never loaded, not even an Error 404 page.  Idk what happened lol.  But RMS still had downloads, and on their page there's a Warning/Notice that...:
Quote from: RMS
If you downloaded before August 25th, 2011.
You must download the new patchers ( &, replace them in your RO folder and run them to get the latest patches.

So I downloaded those files (there's two of them) and presto, I got my client to work again!  (Although I error whenever I run into the new mobs in Dewata and Mandalago, but I think it's operator error.)

Anyway, you might wanna try downloading the new Alternative Renewal patchers.  They differ from RagRay's in that the icon in these new one feature a white beanie on the head of the girl in the icon, versus nothing in the RagRay ones.

P.S.  I also use Windows 7 and have not had issues updating my client since I updated the RSU patchers.


Did you checked if the patch_allow and/or patch_allow_RE[or something like that] is with allow? If they're not with allow you won't patch :O


Trust me, I've tried just about every alternative that I could think of, even reverting back to XP.

But thank you guys, and Crispy, I had no idea those even existed. :v Were they created by kRO? I'll download them and give them a try.


Unfortunately, that didn't work. Just like Ragray and my server's custom kRO patcher, it says failed to receive patch. :\


If the error is like one of the first things happens when you run the patcher (even before it starts patching or "obtaining patch_allowRE.txt"), it sounds like your firewall's kicking the connection, as Eurydice suggested. 

Edit:  Either that, or someone (eg Network, ISP, etc) is blocking you from connecting to kRO's patch server (whose IP is, I believe,


Have you tried using the RSU patcher?
Been hearing from some it's supposed to be better than ragray, haven't used it myself, though.

I had this issue actually with the usual kRO patcher and it actually stopped when switching to ragray and some time later i had major problems with ragray but I quit playing for a while anyways. x__x


xyuki, that is one of the two patchers I linked in my previous post, that she said did not work for her.  :x


Oh, sorry, I didn't know those files were identical. I thought those were just some updated files, yeah fail for me. x__x


It stop at Failed to retrieve 2009-09-30gdata_k.gpf and the same date but rdata.gpf.

Anyone know if these are file I'm apparently missing?

Also, as I said, I've tried just about everything I can think of. Both my anti-virus and my firewall are turned off, because even adding an exception didn't work.



I've fixed it.

I guess the issue was, I was combining the kRO and kRO-RE downloads with the rsu installers. It was a simple fix by ONLY extracting the installers into a folder with the .dlls. :T

Thank you for your help guys, much, much appreciated.