Game crashes immediately after character select loading screen

Started by alfredsad, Jun 25, 2013, 10:18 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Alright here goes.
So a while back I decided I wanted to play RO once more. And downloaded the full kRO client from RMS. I extracted everything, and then put in the private server files into the folder.
Everything worked fine, i could patch properly, and the game would let me login, up to the character selection screen. I make my character, and then click on enter. This put me to the loading screen. Now here's the odd part. After the loading screen is complete, i can hear the BGM of the main town (prontera) for about 1 second, and then the game just closes itself and im back at my desktop

I hope someone can help me with this problem.
Here are the things I have tried doing :
-Redownloading the kRO client + the private server files and reinstalling them
-Setting my system locale to English
-Run the program in Administrator mode
-Set compatibility setting to Windows XP (service pack 3)

I am running this on Windows 7 (64 bit) . My laptop is pretty new so I dont think it has anything to do with specs.
Tell me if you need any other details :D
Thanks beforehand


Screen size of the window of the game?
Are you sure that the server is made to be fine with kRO?
They've a full client? If yes, try their full client.
Are you sure that their client exe is fine with all languages? I don't really remember this at 100% but you may have to edit the connect file language type info if you're using a non-english OS to solve this[don't really take this as a guaranteed thing, it's just something that I remember].

A screenshot of your ro folder may also help. You may have corrupted/missing files and not noticing them.



Everything seems to be ok after checking the pictures.

What I'm saying is that some people already complained in the past that language type may affect if the server is available to play or not without problems on some OS. I think this was more related to Arabian users.

Btw, you're using which OS?


I am running on Windows 7 Home Premium Service pack 1 (64 bit)


Following the first solution, if you check the regedit, you've numbers at the boxes saying the resolution of the window? May be the problem if you don't.