Error when patching kro sakray

Started by pipi1, Nov 25, 2007, 05:18 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


i just got the new kro 1017 and when i patch it and when it gets to 11/13/07 bGM it gives me a error and stops >> please someone help

QuoteDexter's Sakray Update Package
Put this in your ro folder, and use spatchreader, then rosakfix, and then alt sakray.

Ambrose Merle

eheh...heh... yeah... same issue here. It's a connectivity issue I THINK, not positive though. There ARE links you can get to similar files, however, if not the files themselves for a manual download. hold on a minute...

"In case Sakray and ragnarok do not patch, here is a manual link. Goodluck with it.

Additional data in case that doesn't work can be found here:

I have no instructiosn to use with this."

Good luck


Dexter's Sakray Update Package
Put this in your ro folder, and use spatchreader, then rosakfix, and then alt sakray.



Er how about pinning this topic up? I'm sure there are a lot of other players who are dying to find the fix for this. I myself took a few weeks before finding it here (because it's only posted like 4 days ago)

Ambrose Merle

If that's the case, then maybe making a guide would be a better thing to do.


 Is there one of those dexter things for Kro? I could use one for mine.


I haven't seen one yet.
I can post my guide though.
Posted on: Dec 10, 2007, 01:26 pm
Here is a link to my guide
If someone is asking on how to update or if they are having errors you believe to be update related, post this code.


Another option is to do a search online for the Valhalla Patcher.

I had problems with my KRO / Sakray, what I was told to do, was to just leave it running for about 30 minutes, to an hour, and even though the whole windows error came up, it'd still patch. (So long as you don't close it down.)

This turned out to work, but, the valhalla patcher was really nice as it patched up both my KRO and Sakray for me without having to use the clients really. :3

Support GM/Moderator at Paper RO.
We have awesome events coming up! :)


why can't i update kro sakray ...... i used dexter's sakray updater but it says i'm not connected to the internet....but i can surf the net... if anyone can help me pls reply (i'm desperate)


Are you using a firewall?
@Inanna, thank you for that info, I will look for the Valhalla Patcher, I see alot of people asking how to update the kRO clients and I am not able to help them.


i was using it when i posted here...but when i turn it off it still gives me the same error


Ok, go [Here]
That has a kRO and Sak updater.
If that fails, delete the folder, and make a new one with the kRO and Sak, update, then put in the server files.


still no still gives me the same error...i reinstalled the game but still no luck...why is it giving me that error (T_T)


Hmm...if that is the case then it sounds like a corrupt patch.


er... Vahalliah wont says  the following

This Application has failed to start beacuse MSVBVM50.DLL was not
found. Re-installing the application may fix this problem.

OMFG help !! >.< i was looking at hairs on server then i got errored..
i cant log on without getting errored PLZ HELP!!! T.T Ive tried dexters patcher Still nothing and now ive tried this


Can any1 post the korean proxy ?




I got error everytime it started patching. Is it a problem or should i just leave it as it is ?


Hairs are in the server side grf.
User Dexters, then try valhalla, and then the clientpatcher I posted the url to.


I'd like to say that while trying to patch even using one of those programs, I couldn't connect to the server, so I used a South Korean Proxy IP, but the patcher gave me an error so... I kept the south korean IP and used Valhalla patcher and everything went ok.

So if even using one of those programs (dexter's, Valhala, alternate sakray, etc) and and can't patch, check if you can access kRO's home page (, if not then your IP is probably within Gravity's IP block range. Go to Internet Explorer and use a South Korean proxy there (since RO uses IE to patch) and then use one of those third-party patchers, it should solve the problem.


And how do we get a south korean proxy? o.O (newbie at manual patching :( )

edit: Ok, found a guide on proxy-ing IE. Thanks a lot guys, this really helps. Left RO for 2 months cause I had to pull up my grades, so its really out of date.


Quote from: hobbieman on Oct 30, 2008, 12:03 PM
And how do we get a south korean proxy? o.O (newbie at manual patching :( )

edit: Ok, found a guide on proxy-ing IE. Thanks a lot guys, this really helps. Left RO for 2 months cause I had to pull up my grades, so its really out of date.

how to proxy-ing IE? I can't >.<

*Thank You very much for Azurene*

The world is getting more and more broken everyday...

Sorry but you are not allowed to view spoiler contents.


Hey guys...  I've got some problem.  Usually it's something that has been said earlier in the thread, but I think this one's different.  I'm playing CeresRO.  Alright, the problem started yesterday.  I opened the patch, and this error came up, something about some patch list parse error.  I tried opening CeresRO's website (, but it led me to  I don't know why.  Is it something wrong with the website or the CeresRO itself?  I asked my friend to try it, but he managed to open it o_O  Oh, by the way, the error opened up when I tried to open the CeresRO patch (the patching before you click 'start' to play your private server).

Anyway, here was the error that showed up.  Sorry if I can't show a picture...


Patch list parse error (expected non-zero patch number), around "<!DOCTYPE HTML PUBLIC " - //IETF//DTD HTML 2.0// EN">"

Yeah...  Please help???  Sorry if it's not topic-related.


can i ask if the latest patch for kRO 1210 is in 2009-02-04 npkey.rgz? coz my patcher always stops in that patch.. please help thanks


I am getting the same problem was watdfck. It happens when I patch both Ragnarok and Sakray. When I restart the patcher afterwards, it starts all over again. I have re-downloaded both ragnarok and sakray. I am currently between servers, so I downloaded a few while I was shopping. Most recent servers: Phase, Y-mir, Destina, and Justice. All were uninstalled at the time of errors. The only reason I mention it is that, when I uninstalled everything (including RO and Sakray) to fix it, a folder remained the RO folder called nProtect. I am the administrator and I have taken possession of the file, but it still won't let me delete the folder. As you can see by the screen shot, nProtect is causing the error. Please help me!!!!!! T_T


The topic has been bumped a few times since 2007~2009 ... watdfck's problem is from Feb. 

I don't believe you can't remove a file in your own file system.  Try restarting the comp if you suspect some program is using it.  When delete what is the error you get?

If needed, just use the Windows command prompt and type like "del C:\Program File\Gravity\RO\nProtect" .. that might work (the content might need to be empty ...), without the quote.  del for delete so be very careful of what you are deleting.