RMS Home | Guide Writing | Test Server | New Servers | Latest Reviews

Author Topic: I require assistance.  (Read 6071 times)

0 Members and 1 Guest are viewing this topic.

Offline Kyar

I require assistance.
« on: Mar 20, 2012, 02:56 am »
I've been trying for weeks now to get my computer to run RO. I've tried three different servers and nothing WORKED. i even had a friend upload his complete folder that WORKED and that still hasn't helped. My problem is whenever I try to log in on a character it gets to 100% and then crashes. This is the error log.
http://pastebin.com/Yv4Sf3pn

Please help me.
« Last Edit: Mar 21, 2012, 10:44 pm by Kyar »

Advertisement

Offline Siege

Re: I require assistance.
« Reply #1 on: Mar 20, 2012, 02:47 pm »
I've been trying for weeks now to get my computer to run RO. I've tried three different servers  WORKE and not patching, i even had a friend upload his complete folder that WORKED and that still hasn't helped. My problem is whenever I try to log in on a character it gets to 100% and then crashes. This is the error log.
http://pastebin.com/Yv4Sf3pn

Please help me.

Hmm that is a big hell of a error o.O

Well here are some common tips

are u sure u got the correct sak etc etc for the server?

can be to u got a virus blocking these applications.

further i cant assistance that kind of error uncommon 1


Offline Kyar

Re: I require assistance.
« Reply #2 on: Mar 21, 2012, 11:26 am »
I've got all the required files and my anti-virus isn't blocking anything (nor is it an actual virus. Just scanned last night and still nothing.)

Offline yC

Re: I require assistance.
« Reply #3 on: Mar 21, 2012, 04:22 pm »
Show an image of your RO folder please.

+ server you are trying to play on.
+ size of your data.grf and rdata.grf.
+ content of data.ini

Offline Kyar

Re: I require assistance.
« Reply #4 on: Mar 21, 2012, 06:47 pm »
Here's a picture of the folder + the data sizes. The server i'm trying to play on is LimitRO (renewal)

http://i.imgur.com/brqdi.png

..And for some reason i'm unable to locate my data.ini. Infact I may not have one (which quite frankly, could be the source of my issue but i'm unsure.)

Offline yC

Re: I require assistance.
« Reply #5 on: Mar 21, 2012, 10:37 pm »
No, not all server use a data.ini especially the renewal ones.  It's fine if you don't have one. 

Your folder look fine.  You can't get on ANY server you mean? (the text up there is a bit confusing in meaning)

The error you got seems to be something on screen that you don't have or the client exe can't handle so it crashes you.  Since you got to the char screen at least, it shouldn't be your video card or computer problem.

Have you try to have your friend make an account, move the char to an area (no custom map try something like prt_fild01) with no npc, no player, no (custom) monster and take off any customs on the char to see if you can login without crashing?


Offline Kyar

Re: I require assistance.
« Reply #6 on: Mar 21, 2012, 10:55 pm »
Sorry about not being clear. What I meant was no server that I tried worked (tried limit ro, talon ro and lumina ro)

my friend logged me in, got me through the tutorial, put me into prontera field and it worked just fine once. but I went to change my settings and suddenly it started crashing again.

edit: i can SOMETIMES get in on that character but i'm having constant crashes with roughly the same crash log. Something i've noticed is that the launcher and cps.dll or granny2.dll have a ? next to them in the crash log.
« Last Edit: Mar 21, 2012, 11:02 pm by Kyar »

Offline yC

Re: I require assistance.
« Reply #7 on: Mar 21, 2012, 10:58 pm »
The tutorial is the problem?  How bout in town?  Do you get sprite error or just crash when there are a lot of ppl on the screen?

Offline Kyar

Re: I require assistance.
« Reply #8 on: Mar 21, 2012, 11:03 pm »
Trying in town. It's not working at all now.

New error too. Whenever I do manage to get in it just crashes to desktop instantly. No log or anything.
« Last Edit: Mar 21, 2012, 11:12 pm by Kyar »

Offline yC

Re: I require assistance.
« Reply #9 on: Mar 21, 2012, 11:16 pm »
You used the rsu patchers, you patched the server's client, you should have every *.grf the server provided you for download.  There is no reason for you to crash if everything is in your RO folder and up to date.

You are missing *something*.  I suggest you ask in the server's forum probably they can give you some hint of the problem =/

Offline Kyar

Re: I require assistance.
« Reply #10 on: Mar 21, 2012, 11:19 pm »
Alright. Well thank you for trying. I at /LEAST/ made progress on this effort.

Offline yC

Re: I require assistance.
« Reply #11 on: Mar 22, 2012, 03:01 am »
Just rechecked your RO folder ss and I found that your rdata.grf is only 174mb.  My two rdata.grf in two different install are both around 476mb~.  That could be the problem.

Did you run both the rsu-patchers to patch completely?  Sometimes you have to run the renewal patcher, then the kRO patcher and run the renewal patcher again (I just do this to make sure they are both all patched).  Also want to know where you got your RO client. 

Offline Kyar

Re: I require assistance.
« Reply #12 on: Mar 22, 2012, 12:05 pm »
I've used the various rms client downloads + the lite limitro. I've also tried the full limitRO installer and like I mentioned before I had my friend upload his entire ro folder and I downloaded that. Nothing works. It COULD be that its the japanese system locale but the problem with that is I've only ever used english. As for the rdata every rdata i've downloaded has been around 160~279. I haven't found one in the 400's yet.

edit: I've also fully patched several times. Still nothing.
« Last Edit: Mar 22, 2012, 12:11 pm by Kyar »

Offline yC

Re: I require assistance.
« Reply #13 on: Mar 22, 2012, 01:16 pm »
The rdata.grf starts out 180~200mb for me, after several months of patching it is now 476mb.  Well if it works for your friends I have no reason to doubt it's a problem.  If kRO removed some files (such as the christmas / luna new year stuff) from the patcher we can surely have different rdata sizes.

Good luck with solving it ...

Offline Strudel

Re: I require assistance.
« Reply #14 on: Mar 22, 2012, 05:33 pm »
Hi, so I didn't read all and I have no clue what server you're on but I was linked to this page.
Your first pastebin error shows that you're missing new_1-1.rsw which is the new ground (novice ground) map.
You can figure that out by opening the pastebin or crash log and ctrl+f then search for "failed" that will show you if the error is data related meaning like, data.grf, rdata.grd, ldata.grf or w/e.
Best way to solve this is to uninstall w/e ragnarok you're using and download the full client.
the new_1-1.rsw error comes from the file missing inside the data.grf, which is around 1.54gb or bigger nowadays.

From also going back to the post and looking where there're links I see that your data.grf and rdata.grf are both too small, so I highly recommend downloading the full client, I also see you're using LimitRO renewal or at least it was mentioned, we had ours updated only a while ago so patching kRo won't event be that much of a bother, and you won't get those weird errors.

On another note, next time I suggest posting it in the limitro renewal forum rather than here, considering this is a ragnarok forum not a specific private server's personal forum.
« Last Edit: Mar 22, 2012, 05:47 pm by Strudel »